Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
White Fungus Growing on my Mashua Tubers Help
Topic Rating: 0 Topic Rating: 0 (0 votes) 
March 9, 2017
8:21 pm
Avatar
Isaac
Guest
Guests

Hi,

I am a first time purchaser of mashua tubers and am having difficulty with a fungus problem. Originally I received 5 tubers and a fungus quickly started growing on them. Acting I removed the portions of the tuber infected with a buffer and planted in newly purchased top soil; however, the fungus has reappeared and now there isn't much left to save. How do I battle this what should I do in the future? It has only been a week and a half since I received my package.

Thanks,
Isaac

March 12, 2017
3:19 pm
Avatar
bill
Moclips, WA, USA
Admin
Forum Posts: 72
Member Since:
August 23, 2013
sp_UserOfflineSmall Offline

Hi Isaac. Fungus on mashua is not a common problem in my experience. I would generally try to wash it off and then plant, but it sounds like it is something aggressive from your description. Please contact us by email about replacement or refund, depending on availability. Sorry about that - tubers are living things and sometimes problems develop during shipping that weren't apparent when they were packed.

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 10

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Filibert: 10

sunbender: 6

rowan.99: 6

libby.cone: 5

Sam: 4

pinverse: 2

Ecophreek: 2

Taylor: 2

kurtkuffer01: 2

Wes: 1

Member Stats:

Guest Posters: 3

Members: 1015

Moderators: 0

Admins: 1

Forum Stats:

Groups: 1

Forums: 1

Topics: 52

Posts: 118

Newest Members:

Angela, RobertWag, Guy, kaidokyk, Dominique, toby, SregoryCah, Jennifer, CaseyNum, Randyweito

Administrators: bill: 72